high

CVE-2026-61824

npm · defuddle

Summary

Defuddle vulnerable to XSS via unescaped attribute interpolation in site extractors

Severity
high
CVSS
8.2
EPSS
0.4% (p35)
CWE
CWE-79, CWE-116
Also known as
GHSA-jg4p-g6xj-4qmf
Published
2026-08-21
Updated
2026-08-21

Advisory details

Summary

An Improper Neutralization of Input During Web Page Generation issue in the site extractor component allows an attacker-controlled attribute value to be injected into output HTML without escaping. An attacker who crafts a malicious HTML page or controls content on a matching domain can execute arbitrary scripts when a victim processes the page, resulting in Cross-Site Scripting (XSS). This affects defuddle through 0.19.0 and has been patched in version 0.19.1.

Impact

This vulnerability allows for Cross-Site Scripting (XSS) execution without needing to compromise external websites. Affected consumers include:

Patch

This issue has been patched in defuddle version 0.19.1. Users are encouraged to update to the latest release.

References

Related advisories

Is your project exposed to this? Stateward checks every dependency on every pull request and flags it only if your code actually reaches it.

Check my repo

Summarize with AI

ChatGPTClaudePerplexity

Sources: CISA KEV (public domain), OSV.dev & GitHub Advisory Database (CC-BY-4.0), FIRST EPSS, NVD/CWE (public domain). Served live from the Stateward advisory database.