critical

CVE-2026-62379

Maven · org.openidentityplatform.openam:openam-core

Summary

OpenAM: Unauthenticated Remote Code Execution via Class.forName in AuthXMLUtils.createCustomCallback

Severity
critical
CVSS
9.8
EPSS
1.1% (p65)
CWE
CWE-94, CWE-470
Also known as
GHSA-wg5r-wc3x-39vc
Published
2026-07-24
Updated
2026-07-24

Advisory details

Summary

A pre-authentication remote code execution vulnerability affects OpenAM. The remote authentication endpoint (/authservice, PLL) accepts an XML element that names an arbitrary Java class, which the server then loads and instantiates without validation. On a default configuration this is reachable without authentication and allows an attacker to run code on the server.

Impact

Unauthenticated remote code execution / full server compromise on any OpenAM instance with default settings.

Affected

All releases up to and including 16.1.1 (the defect predates the Open Identity Platform fork).

Remediation

Upgrade to 16.1.2.

Interim mitigation

Credit

Vulnerability discovered by Zhixi "Jace" Sun of ASM/VI at TikTok.

References

Related advisories

Is your project exposed to this? Stateward checks every dependency on every pull request and flags it only if your code actually reaches it.

Check my repo

Summarize with AI

ChatGPTClaudePerplexity

Sources: CISA KEV (public domain), OSV.dev & GitHub Advisory Database (CC-BY-4.0), FIRST EPSS, NVD/CWE (public domain). Served live from the Stateward advisory database.